## Contents

### Chapter 1

**Using This Guide** .............................................1

- Audience ...................................................................................1
- Organization of This Document ................................................1
- Minimum System Requirements ...............................................2
  - Elluminate Live! Server .........................................................2
  - Elluminate Live! Manager ......................................................4
  - Elluminate Live! Clients ........................................................5
  - Recommended Video Cams .................................................6
- What’s new in Elluminate Live! 7.0? .........................................7
  - New Features in Elluminate Live! 7.0 .....................................8
- What’s new in Elluminate Live! Manager 2.0? ..........................16
- Contacting Elluminate Technical Support ...............................17

### Chapter 2

**Overview of Elluminate Live!** ......................19

- The Elluminate Live! Server ....................................................20
- The Elluminate Live! Client .....................................................20
- Elluminate Live! Manager 2.0 .................................................20
- Mckoi SQL Database ................................................................21
  - Acknowledgements .............................................................21
- BlackBoard Adapter ............................................................21
- WebCT Adapter ......................................................................21
- Supporting products ................................................................22
  - Java Access Bridge ..............................................................22
  - PowerPoint Converter Tool .................................................22
  - WebLauncher 2.0 ..................................................................22
  - Elluminate Live! Software Developer’s Kit (SDK) .................23
- Presentation Wizard ...............................................................23
- Future tools, adapters and integrations ..................................23

### Chapter 3

**Typical Installation** .............................................25

- Console Mode Installation .......................................................25
- GUI Installation ......................................................................26
<table>
<thead>
<tr>
<th>Chapter 4</th>
<th>Custom Installation .................................................39</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prerequisites to a Custom Installation ...................................39</td>
<td></td>
</tr>
<tr>
<td>1. LDAP Attribute Definition ............................................39</td>
<td></td>
</tr>
<tr>
<td>2. Password Encryption ..................................................40</td>
<td></td>
</tr>
<tr>
<td>3. Non-McKoi Database ..................................................40</td>
<td></td>
</tr>
<tr>
<td>4. Multiple Elluminate Live! Servers .....................................41</td>
<td></td>
</tr>
<tr>
<td>Console Mode Installation ...............................................42</td>
<td></td>
</tr>
<tr>
<td>GUI Custom Installation Steps .........................................42</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 5</th>
<th>Start, Stop, and Restart the Services and Daemons ..................69</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows .................................................................69</td>
<td></td>
</tr>
<tr>
<td>Linux, Solaris ...........................................................70</td>
<td></td>
</tr>
<tr>
<td>Macintosh .................................................................71</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 6</th>
<th>Post Configuration and Verification .....................................73</th>
</tr>
</thead>
<tbody>
<tr>
<td>Configure the serversupport's and legacyadapter's email addresses ..................................73</td>
<td></td>
</tr>
<tr>
<td>Verify that the Installation was Successful ........................................75</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 7</th>
<th>Uninstalling Elluminate Live! ...........................................79</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows Uninstall .........................................................79</td>
<td></td>
</tr>
<tr>
<td>Linux &amp; Solaris Uninstall ..................................................79</td>
<td></td>
</tr>
<tr>
<td>GUI Mode Uninstall ..........................................................80</td>
<td></td>
</tr>
<tr>
<td>Console Mode Uninstall .....................................................82</td>
<td></td>
</tr>
<tr>
<td>Mac Uninstall .................................................................82</td>
<td></td>
</tr>
<tr>
<td>GUI Mode Uninstall ..........................................................82</td>
<td></td>
</tr>
<tr>
<td>Console Mode Uninstall .....................................................82</td>
<td></td>
</tr>
</tbody>
</table>
Chapter 1 Using This Guide

The Standard Installation Guide contains information you may need to install the Elluminate Live! 7.0 with Elluminate Live! Manager 2.0 software.

An additional manual called the Advanced Configuration Guide is also available on the Installation CD. The Advanced Configuration Guide provides additional information for the advanced users such as how to administer the Elluminate Live! servers, troubleshooting procedures, and post installation and configuration procedures.

Audience

This guide is intended for anyone responsible for the preparation, installation and administration of Elluminate Live! Manager, Elluminate Live! Server, and Elluminate Live! License Manager.

It is assumed that the user has a basic working knowledge in the following:

- The operating systems, which will be used to host Elluminate Live! clients and servers:
  - Microsoft Windows™
  - Apple Macintosh™
  - Sun Solaris™
  - Linux Red Hat Enterprise Edition™
  - SUSE Linux Enterprise Server
- The administration of the WebCT Vista 3.0/4.0 or Campus Edition 6.0 servers (if you are using the WebCT Adapter).
- The administration of the BlackBoard server versions 6.0, 6.1, 6.2, and 6.3 (if you are using the BlackBoard LMS).

Organization of This Document

This document is organized in the following chapters:

- Chapter 1, Using This Guide — Describes the intended audience, and how the manual is organized; lists the system requirements for the Elluminate Live! License Manager, Elluminate Live! Server, Elluminate Live! Manager, clients, and identifies the new features in Elluminate Live! Manager 2.0.
Chapter 1 Using This Guide

- Chapter 2, Overview of Elluminate Live! — Provides a complete overview of Elluminate Live! and its supporting products.


- Chapter 4, Custom Installation — Provides step-by-step instructions on how to perform a custom installation.

- Chapter 5, Stop, Start, and Restart the Daemons and Services — this chapter describes the commands used to stop, start, and restart the services or daemons based on your operating system.

- Chapter 6, Post Configuration and Verification — After installing the Elluminate Live! software, it is advisable to update the default serversupport’s email address and to run a quick check to verify that all the components have been installed correctly. This chapter provides basic step-by-step procedures on how to edit the serversupport’s user profile, create a basic meeting, send an email notification to the meeting, join the meeting, record the meeting, and playback the recording.

- Chapter 7, Uninstalling Elluminate Live! — Describes how to uninstall Elluminate Live! services.

Minimum System Requirements

This section lists the system requirements for the Elluminate Live! Server, Elluminate Live! Manager, clients, and recommend video cameras.

Elluminate Live! Server

An Elluminate Live! Server is essentially a very sophisticated data packet switching application that consumes CPU, RAM, and network bandwidth. It is a memory resident program that does not have to perform any database operations and performs minimal disk IO. It has been optimized to limit the memory footprint required for each room participant.

The key element for Elluminate Live! Server performance is peak usage. If the peak level can be supported, then other usage levels are not an issue. Essentially, an Elluminate Live! Server will work optimally as long as:

- There is available CPU resource. Every 25 users require about 250 MHz of speed from a P4/Xeon/G5 type processor or about 150 MHz of speed from an X2/Opterion/UltiSPARC type processor.
- There is sufficient memory. The recommended amount is 128 MB of allocated memory plus an additional 50 MB for every 25 users.

- There is sufficient network bandwidth to the clients. At least 1 Mbps of outbound bandwidth for every 25 users is recommended.

These recommendations assume an average room size of 25 participants or less. Larger rooms place higher instantaneous loads on the server and the required hardware configuration will increase accordingly. The CPU, RAM, and network bandwidth requirements will need to be doubled to hold single sessions with as many participants as your license will allow.

As long as these recommendations are met, installing Elluminate Live! on faster servers will not necessarily affect performance. However, a more powerful machine can reduce risk of service slowdown under very heavy loads.

For installations of 100 seats or less, the minimum requirements for a single combined system would be:

- Operating System — Windows 2000 or 2003 Server; Mac – OS X 10.4; Solaris 9/10 (SPARC or x86); RedHat Enterprise Linux - v4 for x86, Novell SUSE Linux Enterprise Server (SLES9).

- Processor — 1.2 GHz Pentium 3 (Windows, Linux, or Solaris); 2 GHz G5 (Mac OS X and Mac OS X Server), 750 MHz UltraSPARC II (Solaris)

- Memory — 512 MB of RAM.

- Network — Static IP address with 1-2 Mbps outbound bandwidth for every 25 users. Firewall access permitting connections to the server’s Conference Ports for Elluminate Live! 7.0 Clients, and to the Control Port for administrators.

- Disk Space — 400 MB of free disk space. This does not include the optional space required for extended log files and session recordings. In general, log files grow slowly, but about 5-10 MB of disk space could be required for each recorded 1-hour session.

For installations of over 100 seats, it is recommended that you meet the minimum requirements (as stated above) and the Elluminate Live! Manager resides on a separate system.

The following changes would meet the recommendations for a dedicated Elluminate Live! Server for 400 seats or less:

- Processor — Dual core 2.2 GHz Opteron or 3.6 GHz P4/Xeon (Windows, Linux, or Solaris); Dual 2 GHz G5 (Mac OS X and Mac OS X Server); Dual 1.3 GHz UltraSPARC III (Solaris)

- Memory — 1 GB of RAM.
Chapter 1 Using This Guide

The following changes would meet the recommendations for a dedicated server for 800 seats or less:

- Processor — Dual core 2.2 GHz Opteron or dual core 3.7 GHz Xeon (Windows, Linux, or Solaris); Quad 1.6 GHz UltraSPARC III (Solaris); Single 1 GHz T1 chip, 6 core (Solaris)
- Memory — 2 GB of RAM.

---

Elluminate Live! Licenses seats can be served on more than one machine for both redundancy and for virtually unlimited scalability.

Elluminate Live! Manager

Elluminate Live! Manager is a web-based environment for managing and launching Elluminate Live! sessions. Elluminate Live! Manager may be installed on the same system as the Elluminate Live! Server or on a separate machine. For installations of over 100 seats, it is recommended that Elluminate Live! Manager is installed on its own system.

Like any web based server application, Elluminate Live! Manager’s hardware requirements are dependent on the size of the user base, however minimum requirements for Elluminate Live! Manager include:

- Operating System — Windows 2000 or 2003 Server; Mac – OS X 10.4; Solaris 9/10 (SPARC or x86); RedHat Enterprise Linux – v4 for x86, Novell SUSE Linux Enterprise Server (SLES9).
- Disk Space — 250 megabytes of free disk space. This does not include the optional space required for data files for meetings, users, and session recordings.
- Network — static IP address.
- Internet connectivity with firewall access permitting a connection to the Elluminate Live! Server’s Conference Ports.
- Processor — A 500 MHz Pentium 3 for Windows and Linux; a 300 MHz UltraSPARC II processor for Solaris; or at least a 625 MHz G4/G5 for Mac OS X.
- Memory — 256 MB of RAM.


**Elluminate Live! Clients**

**Windows:**
- Windows 98/ME/2000/XP
- Pentium III 500 MHz processor
- 128 MB RAM (98/ME) 256 MB RAM (2000/XP)
- 20 MB free disk space
- Soundcard with speakers and microphone or headset
- 28.8 kbps Internet connection

**Macintosh:**
- Mac OS 9.2, Mac OS X 10.2.8, 10.3.9, and 10.4
- G3, G4, G5, or Intel processor
- 128 MB RAM (OS 9.x), 256 MB RAM (OS X)
- 20 MB free disk space
- Microphone (internal, USB, or iSight)
- 28.8 kbps Internet connection

**UltraSPARC Solaris:**
- Solaris (SPARC only) 9 and 10
- UltraSPARC llc 300 MHz
- 128 MB RAM
- 20 MB free disk space
- Soundcard with speakers and microphone or headset
- 28.8 kbps Internet connection

**Java Desktop System:**
- Java Desktop System 3
- Pentium III 1 GHz processor
- 256 MB RAM
- 20 MB free disk space
Chapter 1 Using This Guide

- Soundcard with speakers and microphone or headset
- 28.8 kbps Internet connection

Recommended Video Cams

Elluminate Live! supports 24 Bit RGB Color, many compressed video formats, Direct X video and high end cameras such as FireWire Sony Camcorders. Some cameras that do not have a CODEC for 24 Bit RGB Color support may not work within an Elluminate Live! session.

A list of cameras that are known to work with Elluminate can be found here:

http://www.elluminate.com/support/faqs/camera_supported.jsp
What’s new in Elluminate Live! 7.0?

There are four different editions of Elluminate Live! 7.0 - Lite, Basic, Academic, and Enterprise. The following table lists what features are available for each edition.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Versions of Elluminate Live! 7.0</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Lite</td>
</tr>
<tr>
<td>Whiteboard</td>
<td>X</td>
</tr>
<tr>
<td>Direct Messaging</td>
<td>X</td>
</tr>
<tr>
<td>Closed Captioning</td>
<td>X</td>
</tr>
<tr>
<td>Graphing Calculator</td>
<td>X</td>
</tr>
<tr>
<td>Polling, Hand Raising, Stepped Out, etc.</td>
<td>X</td>
</tr>
<tr>
<td>Voice over IP – including multiple talkers</td>
<td>X</td>
</tr>
<tr>
<td>Application Sharing</td>
<td>X</td>
</tr>
<tr>
<td>Recordings</td>
<td>X</td>
</tr>
<tr>
<td>User Profiles</td>
<td>X</td>
</tr>
<tr>
<td>Breakout Rooms</td>
<td>X</td>
</tr>
<tr>
<td>Video</td>
<td>X</td>
</tr>
<tr>
<td>Web Tours</td>
<td>X</td>
</tr>
<tr>
<td>Multimedia</td>
<td>X</td>
</tr>
<tr>
<td>Quiz Manager</td>
<td>X</td>
</tr>
<tr>
<td>File Transfer</td>
<td>X</td>
</tr>
</tbody>
</table>
# New Features in Elluminate Live! 7.0

Release 7.0 of Elluminate Live! is an upgrade from Elluminate Live! 6.5 with Elluminate Live! Manager 2.0 that includes several new features and a number of improvements in both the client and the server. The following table lists the major moderator and participant features.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General Look and Feel</strong></td>
<td>The Elluminate Live! 7.0 adopts the native look and feel of either a Windows or Mac OS X application. All other platforms will have the Metal look and feel as with earlier releases of Elluminate Live!. A new menu called Window has been added. Selecting a specific option in the menu will call up the appropriate window. The options available are: Closed-Captioning, File Transfer, Graphing Calculator, Multimedia Library, and Quiz Manager. Except for the Mac, all menu items now have mnemonics to facilitate navigation with the keyboard. On Windows and Mac OS X, the Theme item in the View menu has been removed. Dialog boxes can all be dismissed with the Escape key.</td>
</tr>
<tr>
<td><strong>Mini-Controller</strong></td>
<td>The mini-controller toolbar provides the ability to manage the Elluminate Live! main window and Application Sharing session with a minimum on-screen presence. When the mini-controller view is enabled, the Elluminate Live! main window is minimized and in its place is a small toolbar. The mini-controller toolbar may be placed in one of the four corners on your monitor. The user will be permitted to change the corner that the mini-controller is displayed. The buttons that are available in the toolbar will vary depending on what features you have currently enabled in the session. Some of the toolbar buttons may also have an associated contextual (right-click) menu. You may switch to the mini-controller view in one of three ways:</td>
</tr>
<tr>
<td></td>
<td>1. Using the default hot key Ctrl+F9. Ctrl+F9 will toggle between the mini-controller view and the Elluminate Live! main window view.</td>
</tr>
<tr>
<td></td>
<td>2. Menu command: View &gt; Switch to Mini-Controller</td>
</tr>
</tbody>
</table>
|                       | 3. When hosting an Application Sharing session. In the Hosting Options dialog box, when the option Switch to mini-controller is selected, when you start application sharing, your view will switch from the Elluminate Live! main window to the mini-
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application Sharing</td>
<td>You may immediately start sharing your entire desktop simply by going to Tools &gt; Application Sharing &gt; Share Entire Desktop. Selecting this option immediately begins a whole desktop share. Whatever Hosting Options have been defined will apply. This method bypasses the Hosting Options dialog box.</td>
</tr>
<tr>
<td>- Share Entire Desktop</td>
<td></td>
</tr>
<tr>
<td>Application Sharing</td>
<td>You may immediately start sharing an application simply by going to Tools &gt; Application Sharing &gt; Share Application and then from the submenu, select the running application you wish to share. Sharing begins immediately. Whatever Hosting Options have been defined will apply. This method bypasses the Hosting Options dialog box. You may only share one application using this method.</td>
</tr>
<tr>
<td>- Sharing an application</td>
<td></td>
</tr>
<tr>
<td>Application Sharing</td>
<td>This feature is available when you are hosting an application sharing session. The Show Preview Window feature launches an extended panel that displays a thumbnail view of the hosted application sharing session. Menu Command: Tools &gt; Application Sharing &gt; Show Preview Window Mini-controller: Click on the Show the application sharing preview window button.</td>
</tr>
<tr>
<td>- Show Preview Window</td>
<td></td>
</tr>
<tr>
<td>Application Sharing</td>
<td>This feature is available when you are hosting an application sharing session. When you have engaged the Application share snapshot to whiteboard, the Application Share feature takes a snapshot of the hosted Application Sharing session, pauses hosting, causes all the clients to hide their Application Sharing window in favor of the Whiteboard window and sends the snapshot to the Whiteboard in a new screen. Menu Command: Tools &gt; Application Sharing &gt; Send Snapshot to Whiteboard Mini-controller: Click on the Application share snapshot to whiteboard button. The mini-controller toolbar will switch to the Elluminate Live! main window with the snapshot of the application sharing session in the Whiteboard window.</td>
</tr>
<tr>
<td>- Snapshot to whiteboard</td>
<td></td>
</tr>
<tr>
<td>Application Sharing</td>
<td>The host of an application sharing session will be able to filter out prohibited keystrokes if sent by a remote controller. There is a set of default keystrokes that will be filtered based on the operating system. These keystrokes are blocked for Desktop, Region, and sharing</td>
</tr>
<tr>
<td>- Filtered Keystrokes</td>
<td></td>
</tr>
</tbody>
</table>
### Chapter 1 Using This Guide

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Feature</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>applications.</td>
<td>The user may modify, add, or remove any of these keystrokes. Menu Command: Tools &gt; Application Sharing &gt; Filtered Keystrokes The default keystrokes are: Windows: Ctrl+Alt+Delete Linux/Solaris: Ctrl+Alt+Backspace Ctrl+Alt+Delete Macintosh: Command+Shift+Q Command+Alt+Escape Command+Alt+Shift+Q</td>
</tr>
<tr>
<td>Application Sharing - Simulated Keystrokes</td>
<td>A remote controller of an application sharing session may send a simulated keystroke to the host of the application sharing session. By default, there is a set of simulated keystrokes that may be sent based on the operating system. The user may modify, add, or remove any of these keystrokes. Menu Command: Tools &gt; Application Sharing &gt; Simulated Keystrokes The default keystrokes are: Windows: Ctrl+Escape Ctrl+Tab Alt+Tab Alt+Shift+Tab Meta+C, triggered on Ctrl+C, only when host is a Macintosh Meta+X, triggered on Ctrl+X, only when host is a Macintosh Meta+V, triggered on Ctrl+V, only when host is a Macintosh Linux/Solaris: Ctrl+Escape Alt+Tab Alt+Shift+Tab Alt+Escape Alt+Space Meta+C, triggered on Ctrl+C, only when host is a Macintosh</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Meta+X, triggered on</td>
<td>Meta+X, triggered on Ctrl+X, only when host is a Macintosh Macintosh controllers (both OS 9 and OS X):</td>
</tr>
<tr>
<td>Ctrl+X, only when</td>
<td>Command+Space \n Command+Tab \n Command+Shift+Tab \n F9 \n F10 \n F11 \n F12 \n Macintosh controllers (OS X): \n F9 \n F10 \n F11 \n F12</td>
</tr>
<tr>
<td>host is a Macintosh</td>
<td>Application Sharing - Send Key</td>
</tr>
<tr>
<td>- Send Key</td>
<td>When a user is remotely controlling another session, the Send simulated keystroke to host button appears in the toolbar. To send a simulated</td>
</tr>
<tr>
<td></td>
<td>keystroke, click on the button and select the keystroke from the contextual menu. Menu Command: Tools &gt; Application Sharing &gt; Send Key</td>
</tr>
<tr>
<td>Audio - Multiple</td>
<td>A session shall support up to 4 simultaneous talkers. Every moderator shall have the ability to limit the number of simultaneous talkers per room.</td>
</tr>
<tr>
<td>Talkers</td>
<td>The default setting is 2. Menu Command: Tools &gt; Audio &gt; Allow Simultaneous Talkers Within the Limit Talkers Per Room dialog box the moderator will see the</td>
</tr>
<tr>
<td></td>
<td>current limit, the possible limits, and be able to change the current limit of simultaneous talkers.</td>
</tr>
<tr>
<td>Audio - Talk button</td>
<td>The Talk button now displays the current audio hotkey. When multiple simultaneous talkers have been granted audio privileges, the caption line on the</td>
</tr>
<tr>
<td>- Caption Line</td>
<td>Audio window shall say ‘Audio - Multiple Talkers’ and not the name of the people who are talking. When only one person has enabled the Audio the caption</td>
</tr>
<tr>
<td>- Volume control</td>
<td>line will display the name of the talker. When there are multiple talkers currently talking, when a moderator clicks on the volume control buttons that</td>
</tr>
<tr>
<td>buttons</td>
<td>appear in their Audio window, a contextual menu will appear asking the moderator to choose from a list of users which user is to have their mic volume adjusted.</td>
</tr>
</tbody>
</table>
# Chapter 1  Using This Guide

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Breakout Rooms</strong></td>
<td><strong>- Rename</strong></td>
</tr>
<tr>
<td></td>
<td>A moderator will have the ability to rename a breakout room, keeping the room's contents and participants intact.</td>
</tr>
<tr>
<td></td>
<td>To rename a breakout room, you must first highlight the breakout room in the Participant Info window and then do one of the following:</td>
</tr>
<tr>
<td></td>
<td>Menu command:  Tools &gt; Breakout Rooms &gt; Rename Breakout Room</td>
</tr>
<tr>
<td></td>
<td>From the contextual menu in the Participant Info window select Rename Breakout Room…</td>
</tr>
<tr>
<td><strong>Breakout Rooms</strong></td>
<td><strong>- Auto Distribution</strong></td>
</tr>
<tr>
<td></td>
<td>A moderator now has the ability to automatically distribute participants and moderators from the main room into breakout rooms.</td>
</tr>
<tr>
<td></td>
<td>Participants may be distributed into different breakout rooms in one of three ways:</td>
</tr>
<tr>
<td></td>
<td>1. Into the last breakout room that they were in</td>
</tr>
<tr>
<td></td>
<td>2. Divided into N groups</td>
</tr>
<tr>
<td></td>
<td>3. Divided into groups of N</td>
</tr>
<tr>
<td></td>
<td>In addition, the moderator has the option of specifying where the additional moderator(s) in the main room should be distributed.</td>
</tr>
<tr>
<td></td>
<td>Menu command: Tools &gt; Breakout Rooms &gt; Distribute Participants</td>
</tr>
<tr>
<td></td>
<td>Another feature of the auto distribution is being able to return all participants and moderators back into the main room.</td>
</tr>
<tr>
<td></td>
<td>Menu command: Tools &gt; Breakout Rooms &gt; Return Everyone to Main Room</td>
</tr>
<tr>
<td><strong>Breakout Rooms</strong></td>
<td><strong>- Polling</strong></td>
</tr>
<tr>
<td></td>
<td>Polling summaries are now breakout room specific. Each breakout room may have its own unique polling mode, with its own results and statistics.</td>
</tr>
<tr>
<td></td>
<td>A moderator assigned to a breakout room may set the polling option.</td>
</tr>
<tr>
<td><strong>Direct Messaging</strong></td>
<td><strong>- Send Text</strong></td>
</tr>
<tr>
<td></td>
<td>You are now able to change the font size of the send text in the Direct Messaging window.</td>
</tr>
<tr>
<td></td>
<td>Menu command: Tools &gt; Direct Messaging &gt; Send Area</td>
</tr>
<tr>
<td></td>
<td>Direct Messaging window: A contextual (right-click) menu appears when you click in the Sent Textbox area of the Direct Messaging window.</td>
</tr>
<tr>
<td></td>
<td>There are four options: Make Text Bigger, Make Text Smaller, Restore Default, and Text Size. The option Text Size contains a list of available font sizes. The default font size is 12.</td>
</tr>
<tr>
<td><strong>Direct Messaging</strong></td>
<td>Specific text strings for laughter, confused, surprised, wink, sad, and...</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>- Emoticons</td>
<td>angry will now be displayed graphically when entered in the Direct Messaging window. Laughter with :-) or :) or :D Confused with :S Surprised with :-o or :-O or :-0 or :^) Wink with ;-) or ;) Sad with :-( or :( Angry with :@</td>
</tr>
<tr>
<td>Hot Key Configuration - Application share snapshot to whiteboard</td>
<td>A hot key has been defined to enable the Application share snapshot to whiteboard. The default hotkey definition is Ctrl+Print Screen (Mac only: Ctrl+F13) You must be currently hosting an application sharing session for the hotkey to work.</td>
</tr>
<tr>
<td>Hot Key Configuration - Show/hide mini-controller</td>
<td>A hot key has been defined to Show/Hide the Mini-Controller. The default hotkey definition is Ctrl+F9.</td>
</tr>
<tr>
<td>Hot Key Configuration - Stop/start video transmission</td>
<td>A hot key has been defined to start/stop transmitting video. The default hot key definition is Ctrl+F3 When Video camera support has been enabled, pressing Ctrl+F3 will open the Video window. If the Video window was already open, then pressing Ctrl+F3 will start the video transmission (equivalent to pressing the Transmit button in the Video window). And finally, if you are currently transmitting video, pressing Ctrl+F3 will stop the video transmission. The video hot key is only available on platforms that support video transmit and hot keys.</td>
</tr>
<tr>
<td>Participant Whiteboard Screen Viewing</td>
<td>The moderator has the ability to see what slides selected participants are viewing and optionally go to these slides. To view what slides a participant or participants are viewing, highlight a participant(s) in the Participant Info window and then right-click. A contextual menu appears with the option Whiteboard &gt; Show Participant Screen Names. In the Screens Viewed by Students dialog box, each of the participants will be listed and will show the name of the screen that they are viewing. If you wish to go directly to the screen that is being viewed, right-click on the screen name and then click on the Go to button. As the moderator</td>
</tr>
</tbody>
</table>
### Chapter 1 Using This Guide

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>you should now be viewing the same whiteboard as the participant.</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Polling</strong></td>
<td><strong>- Publish Polling Results</strong></td>
</tr>
<tr>
<td></td>
<td>A moderator will now have the ability to publish the polling summary statistics so that other participants in the session can see them. Menu command: Tools &gt; Polling &gt; Show Statistics</td>
</tr>
<tr>
<td></td>
<td>A button has been added to the Polling Summary Statistics dialog box called Publish to whiteboard. When this button is pressed, an image of the Polling Summary Statistics dialog box is captured and added to a new screen on the whiteboard.</td>
</tr>
<tr>
<td><strong>Polling</strong></td>
<td><strong>- Lock Polling Results</strong></td>
</tr>
<tr>
<td></td>
<td>The moderator now has the ability to lock the polling results. Menu command: Tools &gt; Polling &gt; Lock Responses</td>
</tr>
<tr>
<td><strong>PowerPoint Presentation</strong></td>
<td><strong>- Import</strong></td>
</tr>
<tr>
<td></td>
<td>There are five different whiteboard screen size options available when importing PowerPoint presentations. The options are: 800 x 600, 1024 x 768, 1280 x 1024, 1600 x 1600. Canvas Size – when Canvas Size is selected, the screen will be the size of the view port of the canvas. The options are set in the Specify Import Screen Size dialog box. Menu Command: File &gt; Load &gt; Whiteboard</td>
</tr>
<tr>
<td><strong>Raise Hand Option</strong></td>
<td><strong>- Auto Raise Hand</strong></td>
</tr>
<tr>
<td></td>
<td>A moderator can disable or enable the Hand Raised feature when a user joins the session. Menu command: Tools &gt; Interaction &gt; Raise Hand upon Entering</td>
</tr>
<tr>
<td><strong>Raise Hand Option</strong></td>
<td><strong>- Beep when a hand is raised</strong></td>
</tr>
<tr>
<td></td>
<td>A moderator can disable or enable the beep when a hand is raised in the session. Menu command: Tools &gt; Interaction &gt; Beep When Hand is Raised</td>
</tr>
<tr>
<td><strong>Shortcut Keys</strong></td>
<td>There are now shortcut keys defined for raising your hand, to show emotion (laughter, applause, confusion, and disapproval), adjusting your microphone and speaker levels, gaining access to the send text area, and polling responses. Raise Hand: Ctrl+R</td>
</tr>
<tr>
<td>Feature</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Show Emotion</td>
<td>Ctrl+Alt+1</td>
</tr>
<tr>
<td>Show Emotion</td>
<td>Ctrl+Alt+2</td>
</tr>
<tr>
<td>Show Emotion</td>
<td>Ctrl+Alt+3</td>
</tr>
<tr>
<td>Show Emotion</td>
<td>Ctrl+Alt+4</td>
</tr>
<tr>
<td>Adjust Microphone</td>
<td>Ctrl+Shift+Up Arrow</td>
</tr>
<tr>
<td>Adjust Microphone</td>
<td>Ctrl+Shift+ Down Arrow</td>
</tr>
<tr>
<td>Adjust Speaker</td>
<td>Ctrl+Up Arrow</td>
</tr>
<tr>
<td>Adjust Speaker</td>
<td>Ctrl+Down Arrow</td>
</tr>
<tr>
<td>Move focus</td>
<td>Ctrl+M</td>
</tr>
<tr>
<td>Polling Responses</td>
<td>Ctrl+1, Ctrl+2, Ctrl+3, …etc</td>
</tr>
</tbody>
</table>

**User Profiles**

The User Profile feature provides an optional mechanism for users to publish information about them and to view information provided by others.

- Hovering the mouse over a user’s name in the Participant Info window will display the profile data (if any) as a tooltip. If the participant does not have a user’s profile, then the tooltip will display the user’s name.

- Participants and moderators can create their own user profile and store the profile locally. You can save and load a profile as a .vcf file.

- Menu Command: Tools > Profile > Edit Profile

- As a moderator you can decide which user profiles will be displayed in the Participant Info window. The options available are: No one, Moderators, or Everyone.

- Menu Command: Tools > Profile > Show Profiles

**File Transfer**

The File Transfer feature permits files to be uploaded to the server to be shared with everyone in the session. Uploaded files are pushed out to every user in the session at a low priority, but must be explicitly saved by the receiving users.

- Menu Command: Load > File to Transfer

- The library of files available in the session is accessed by selecting the Show the File Transfer window button on the toolbar or selecting the File Transfer option in the Window menu.

- Moderators will automatically be able to transfer files within the Elluminate Live! session. Participants may be given permission to transfer files.
Chapter 1 Using This Guide

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Whiteboard</td>
<td>You may now insert animated GIFs or in the Whiteboard screen.</td>
</tr>
<tr>
<td>- Animated GIFs</td>
<td></td>
</tr>
<tr>
<td>Window Layouts</td>
<td>A new window layout has been added called ‘Whiteboard only’.</td>
</tr>
<tr>
<td></td>
<td>Menu command: View &gt; Window Layouts &gt; Whiteboard Only</td>
</tr>
</tbody>
</table>

New user features are described in detail in the Moderator and Participant Guides included on the Elluminate Live! installation CD-ROM. The server changes are detailed in the appropriate sections of this document.

What’s new in Elluminate Live! Manager 2.0?

Some of the new features and enhancements found in Elluminate Live! Manager 2.0 are:

- Smart Scheduling of Elluminate Live! meetings over multiple Elluminate Live! 7.0 Servers
- User Authentication and Lookup from LDAP v3 Servers
- Enhanced Configuration and Presentation
- Meeting Creation
  - You can invite users to the meeting by selecting their name from a drop down User list and assign the user the role of moderator or participant for the meeting.
  - You can assign multiple moderators per meeting.
  - Preload whiteboard and multimedia files into Elluminate Live!.
  - Reserve seats for the meeting
  - Check the availability of the seats.
  - Add additional teleconferencing messages to moderators and/or participants. This text will appear in the email message sent to them.
  - Set the Recording mode of the meeting to disabled, automatic, or manual.
  - Multiple customizable email invitations for meetings.
- A new Participant/User role has been added.
- Support for JDBC compliant databases
• Reporting capabilities via JDBC
• Password Encryption (3DES and MD5 databases, LDAP – 3DES, MD5, SSHA, and SHA.)

Contacting Elluminate Technical Support

Administrative Technical support is available as follows:

**Email**  support@elluminate.com

**Phone**  1-403-204-7896 (select option 2)
            1-866-388-8674 (select option 4 and then option 2) (Toll Free)
            Monday to Friday: 7:00am – 6:00pm MST

**Fax**  1-403-204-7898

**URL**  [www.Elluminate.com](http://www.Elluminate.com)
Chapter 2  Overview of Elluminate Live!

Elluminate Live! is a Java based client/server application. The Elluminate Live! client runs on Windows™ and Macintosh™ personal computers, as well as Sun’s SPARC and x86 Solaris systems and JDS 3. The Elluminate Live! 7.0 Server software runs on Windows (2000, 2003, and XP Professional), Red Hat Enterprise Linux (EL4), Solaris 9, Solaris 10, SUSE Linux Enterprise Server (SLES9) and Apple Macintosh (includes Xserve) – OS X 10.2, 10.3, and 10.4 (on the PPC only).

The Elluminate Live! 7.0 Client is launched through a web browser interface, using Sun Microsystems’ Java Web Start™. Java Web Start downloads the Elluminate Live! JAR files and then starts the Elluminate Live! 7.0 Client. On Macintosh classic operation systems (Mac OS 9.1 and 9.2) the Open JNLP application WebLauncher, provided by Elluminate, performs the function of Java Web Start.

An Elluminate Live! 7.0 Server acts as a hub connecting Elluminate Live! 7.0 Clients in common meeting rooms (or sessions). Each server provides real-time messaging, interactive graphing, real-time administration, and Voice Over IP (VOIP) to the classroom participants. Each Elluminate Live! 7.0 Server can host multiple rooms.

For creating and managing sessions we include the Elluminate Live! Manager 2.0. An installation of Elluminate Live! Manager provides a quick and easy startup for using Elluminate Live!. Elluminate Live! Manager is considered as part of a standard configuration for Elluminate Live!.

When Elluminate Live! Manager is installed; customers have the ability to integrate the Elluminate Live! Server 7.0 with various adapters. Currently, Elluminate Live! Manager 2.0 can be integrated with the BlackBoard Learning Management System and a WebCT Vista 3.0/4.0 or Campus Edition 6.0 servers. These adapters allow BlackBoard and/or WebCT users to access the Elluminate Live! Manager through BlackBoard or WebCT providing instructors and students a seamless and rich online collaboration.

Furthermore Elluminate Live! Manager when coupled with the Elluminate Live! Software Developer’s Kit (SDK) allows a customer to create his or her own adapter to integrate with the application of choice. Further details on the Customized Configuration are available in the Elluminate Live! SDK.

The major components of Elluminate Live! are summarized below.
Chapter 2 Overview of Elluminate Live!

The Elluminate Live! Server

The Elluminate Live! Server runs as a Service on Windows and as a Daemon process on UNIX.

The Elluminate Live! Server accepts client connections on one or more specified TCP/IP Conference Ports and validates user’s identification. An authorized participant has a single connection to the Elluminate Live! Server and can join with other participants within a session.

When a participant interacts in the session with audio, video, direct messaging, WebTour or by using the whiteboard, data is sent from that participant through this single connection to the Elluminate Live! Server. The server routes the data to all other room participants through their own individual connections. To accommodate participants that may have varying connections speeds, the Elluminate Live! Server manages the bandwidth of all data transfers within the session.

The Elluminate Live! Client

An Elluminate Live! client is a virtual collaboration environment on a Windows or Macintosh personal computer, a Java Desktop System workstation, on a SPARC or x86 Solaris workstation, SUSE Linux Enterprise Server, and a Red Hat Linux EL4 server. The Elluminate Live! client is automatically downloaded, launched, and connected to a specific session on an Elluminate Live! server when the user clicks on the appropriate link in a browser.

Elluminate Live! Manager 2.0

Standard with release 7.0; Elluminate Live! Manager provides a powerful and flexible means of the creation and management of Elluminate Live! sessions, users and recordings. Elluminate Live! Manager 2.0 was designed to meet the needs of organizations by allowing them to leverage their existing IT infrastructure while providing basic needs of organizations that want to get running quickly and easily with Elluminate Live!.

The Elluminate Live! Manager is accessed from a web page using a standard web browser (with scripting enabled). Some of the Elluminate Live! Manager features include:

- User Authentication and lookup from LDAP
- Creation of scheduled and repeating meetings.
- vCalendar notifications for meetings.
- Organization specific help and support page.
- Creation and Management of participants, moderators, and administrators.
- Creation and Management of List of users.
• Management and protection of recordings.
• Playback of version 5.0, 6.0, 6.5, and 7.0 recordings.
• Smart Scheduling of Elluminate Live! meetings over multiple Elluminate Live! 7.0 Servers
• User Authentication and Lookup from LDAP v3 Servers

Mckoi SQL Database

Mckoi SQL Database is an SQL (Structured Query Language) Database management system that was written for the Java platform. Mckoi database is the default database that is installed with the Elluminate Live! Manager 2.0.

The Mckoi SQL Database will store data from the Elluminate Live! Manager replacing the need for *.dat files as used in previous versions.

Acknowledgements

The Mckoi Database Management System (DBMS) is bundled in this application under a special license arrangement with Diehl and Associates. Any usage of the Mckoi DBMS outside of this application is governed by the GNU General Public License located at http://www.gnu.org/copyleft/gpl.html.

BlackBoard Adapter

When Elluminate Live! Manager is installed, a special adapter for BlackBoard allows BlackBoard instructors to create Elluminate Live! sessions for their courses. Sessions and their recordings are easily accessible to students and other instructors.

Complete instructions on how to install the BlackBoard Adapter may be found in the Adapter Configuration manual located in the Documentation folder on the installation CD.

WebCT Adapter

A special adapter for WebCT Vista 3.0/4.0 or Campus Edition 6.0 allows WebCT users to call up the Elluminate Live! Manager via the WebCT server and create Elluminate Live! sessions for their courses. Sessions and their recordings are easily accessible to students and other instructors.
Chapter 2  Overview of Elluminate Live!

To enable WebCT, a hosted instance needs to be created to house all the WebCT meetings. Complete instructions on how to install the hosted instance with the Hosted Configuration Tool, WebCT deployable component, and configuration of the Elluminate Authentication Module proxy tool may be found in the HostedConfigurationTools.pdf and AdapterConfiguration.pdf documents located in the Documentation folder on the installation CD.

Supporting products

Elluminate Live! also has the following products to improve your productivity or leverage your existing applications.

Java Access Bridge

The Java™ Access Bridge is a technology, which allows native assistive technologies (such as screen readers, magnifiers, etc.) to make use of the Java Accessibility API in the Java 2 platform, and thereby provide access to Java applications and applets.

The Java Access Bridge for the Microsoft Windows operating system consists of a pair of Windows DLLs (dynamic link libraries), and a Java language classfile, which together make a bridge for the Java Accessibility API between the Java virtual machine and the Microsoft Windows host platform.

PowerPoint Converter Tool

This product allows the conversion of PowerPoint presentations into a higher quality Elluminate Live! Whiteboard presentation.

To use this tool go to http://www.elluminate.com/support/ppt_converter.jsp and then click on the Launch PowerPoint Converter button.

WebLauncher 2.0

This product allows Mac 9.2 clients to join Elluminate Live! sessions. It is bundled as part of Elluminate Live! 7.0 Server with Elluminate Live! Manager 2.0.
**Elluminate Live! Software Developer’s Kit (SDK)**

Nearing production release this product allows organizations to create custom adapters to integrate with their own content or learning management systems. This product can be ordered from your Elluminate Live! sales representative.

When Elluminate Live! Manager is installed and with the Elluminate Live! SDK; customers may create their own adapters for specific functionality supported in the Elluminate Live! Manager Application Programming Interface (API) – some of these functions include:

- Create a Meeting.
- Update an Existing Meeting.
- Remove a Meeting.
- Create Meeting URL.
- List Recordings.
- Delete a Recording.

**Presentation Wizard**

Nearing production release this product allows the conversion of StarOffice/OpenOffice and PDF files into Elluminate Live! Whiteboard presentations. This product is available from Elluminate’s Support website.

**Future tools, adapters and integrations**

Future products under development or beta testing are available from Elluminate’s Support website.

http://www.elluminate.com/support/
Chapter 2  Overview of Elluminate Live!

This page was intentionally left blank.
Chapter 3  Typical Installation

There are two different installation paths that you may choose from, a typical installation or a custom installation. This chapter will cover a typical installation.

A *typical* installation is for those people who plan to run Elluminate Live! Manager, Elluminate Live! Server, and Elluminate Live! License Manager on a single server. This installation uses the built-in database (Mckoi), which should support small to medium sized organizations. This is similar to earlier versions of Elluminate Live! Manager.

A *custom* installation is generally reserved for the advanced user. This installation is for system administrators who want greater control of the individual components, operate multiple Elluminate Live! Servers, or who wish to integrate with LDAP or JDBC compliant databases. The custom installation is covered in the next chapter.

We recommend the following steps as a guideline for a Typical Elluminate Live! Installation:

1. Install Elluminate Live!
2. Verify that the services are running.
3. Post-installation Configuration and Verification
   - Configure the system administrator email address in the Elluminate Live! Manager.
   - Create a meeting in Elluminate Live! Manager, send email invitation to the meeting, record this meeting, and then playback the recording.

Console Mode Installation

You can install the Elluminate Live! software in either GUI mode or console mode (command mode). If you wish to invoke the installer in command line mode you may do so by navigating to the Setup folder and then selecting the appropriate OS folder (Linux, Mac, or Solaris). Execute the setup program for your environment followed by the `-console` option.

Linux & Solaris:

```
./setupsolarisSparc.bin --console OR
./setupsolarisX86.bin --console OR
./setuplinux.bin --console
```
Chapter 3  Typical Installation

Mac (the following command should be on one line):

```java
```

Follow the GUI Install steps for a definition of the various panels while installing in console mode.

GUI Installation

This section provides guidance and instructions on how to perform a typical installation of Elluminate Live!. The examples below are based on a Windows GUI installation.

By default the Elluminate Live! Manager uses the Tomcat web server. The examples given throughout this manual pertain to the default install and configuration on tomcat.

1. Insert the CD and browse to the Setup folder.
2. Browse to your OS folder and launch the appropriate setup program. For example:
   - **Windows:**
     
    Browse to the CD folder and navigate to `\Setup\Windows` and double-click on `setupwin32.exe` file.
   - **Solaris:**
     
    Open a terminal window, and navigate to `/cdrom/elive70/Setup/Solaris`
    Run the appropriate executable
    For example: `./setupsolarisSparc.bin`
   - **Linux:**
     
    Open a terminal window, and navigate to `/cdrom/elive70/Setup/Linux`
    Run the appropriate executable.
    For example: `./setuplinux.bin`
   - **Mac:**
     
    Browse to your CD folder and navigate to `elive70/Setup/Mac` and double-click on ElluminateLive application.
3. The Welcome panel appears. Click Next > to continue.

4. Accept the license and then click Next > to continue.
5. **Mac ONLY:** You will be asked to provide your password for your account. The account must have administrator privileges. This is required to install Elluminate Live! Server. Click Next > to continue.
6. Define the location of where you wish to install Elluminate Live!

The Elluminate Live! software needs to be installed in a directory on the system. For Windows, the default is C:\Program Files\ElluminateLive. For UNIX the default is /opt/ElluminateLive.

If you wish to change the default directory location, click the Browse button. The Open dialog box appears. Navigate to the folder you wish to use for the directory and then click Open to save the path and dismiss the dialog box.

7. Click Next >.
Chapter 3 Typical Installation

8. Select **Typical**.

9. Click **Next >**.

If you are not installing on a UNIX OS, go to step 11.
Unix ONLY: By default, the Elluminate Live! Server daemon is set to run as root and the run level set to 3 and 5. To accept this configuration click **Next >** and continue with the install.

⚠️ Root must be used if Elluminate Live! Server is going to use a port number less than 1025 (these port numbers are restricted by the OS).

If you wish to change the userID and run levels for the daemon process,

a. Select **Other** and enter your userID in the textbox provided.

b. To change the Daemon Run Level(s), select the appropriate level.

c. Click **Next >** to continue with the install.
10. Define the Elluminate Live! server(s) addresses and port numbers

Define the following fields:

- **Server Address: http://** — enter the hostname or IP address of your Elluminate Live! server.

- **Control Port Number** — The Elluminate Live! Admin Console connects to the Elluminate Live! server on the server’s TCP/IP Control Port. This Control Port must pass through all firewalls between the Admin Console host and the server. The default port number is 2188.

- **Conference Port Number(s)** — The Elluminate Live! client connects to the Elluminate Live! classroom server on the server’s TCP/IP Conference Port number(s). The Elluminate Live! server can listen on a number of Conference Ports. To be accessible, these port numbers must pass through all firewalls between the client and the server. The single default port number is 2187, but alternate or additional ports, generally ports 80 and 443, can be specified to deal with limitations imposed by some firewalls. This can be a single port number or a comma separated list of port numbers.

- **License Manager Port** — enter the port number for the License Manager or accept the default setting.

- **Elluminate Live! Manager Port** — the Elluminate Live! Manager uses Tomcat (on a default port of 80) to serve up pages to the web clients. You may change this port, but you must ensure that this port number can pass through all firewalls between the web browser and the Elluminate Live! Manager. If you plan on
running Elluminate Live! Server on this same machine on port 80 – you’ll need to make some decisions on how to host both services and on which ports. Generally ports 80 and 443, can be specified to deal with limitations imposed by some firewalls.

- *Remote JDBC Port Number* — enter the port number that allows reporting tools to query the database used by Elluminate Live! Manager.

- *Do not check port* — In order to proceed to the next panel, there must be no service listening on the ports. If you have a service currently running on a port AND you will be closing this service after the installation, then check this option. This allows you to proceed to the next panel and continue the install. If you aren’t sure if a service is running on the port and would like to check the port to find out, then do not check this option.

You need to ensure that firewalls allow Elluminate Live! clients to connect through on the conference port you have defined.

By default the installer runs a check on the defined ports. This test is to ensure that the Elluminate Live! 7.0 Server does not conflict with other services on those ports.

11. Click **Next >**.

12. Elluminate Live! License Manager.

   The Elluminate Live! software requires a license file to operate. Two different panels will appear, depending on whether you are installing a Demo License or a Non Demo License. Follow steps a or b depending on the type of license you are installing.

   a. If you selected Demo License (2 User), the following panel appears.
Select the appropriate Demo License type and then click Next >. Proceed with step 14.

b. If you selected Non Demo License, the following panel appears.

Click the Browse button. The Open dialog box appears. Navigate to where your license file is located and then click Open to save the path and dismiss the dialog box and then click Next >.

Define the following fields:

- *Elluminate Live! Server Name* — define the display name for the server when seen from Elluminate Live! Manager.

- *Maximum Utilization Capacity of Server* — this is the number of concurrent Elluminate Live! users that you believe can be supported on the Elluminate Live! Server. Refer to the table defined in the Minimum System Requirements for a general guideline as to the server capacity based on CPU, RAM, processor type, etc.

14. Click **Next >**.

15. Elluminate Live! Manager General Settings
Define the SMTP email server to use for sending out email notifications:

- **SMTP Mail Server** — the name or IP address of the SMTP server used for email invitations.
- **SMTP Server Port** — the port number of the SMTP server used for sending out email invitations.
- **Mail Server requires Authentication** — a user account and password that Elluminate Live! Manager can use on the SMTP server when sending out email invitations. Note: not all SMTP servers require this extra authentication.
- **Ignore SMTP Server Check** — if you do not have access to your mail server or you are not planning on using the email invitations, select this option. By selecting this option, the mail server will not be validated and you will be able to continue with the installation.

16. Click **Next >**.
17. **Elluminate Live! Bandwidth Utilization**

   ![Elluminate Live! Bandwidth Utilization](image)

   Select the optimal network bandwidth for this server.

18. Click **Next >**.

19. **Elluminate Live! Heap Space**.

   ![Elluminate Live! Heap Space](image)

   Maximum Heap Size in Megabytes (Not to exceed physical memory):
   - Elluminate Live! Server: 128
   - Elluminate Live! Manager: 128
   - Elluminate Live! License Manager: 32
Chapter 3 Typical Installation

Allocate the maximum available server heap size for the Elluminate Live! Server and Elluminate Live! Manager. The Elluminate Live! License Manager is set to 32 MB and is not configurable.

20. Click Next.

21. Summary Information.

If the summary information is correct, click the Install button to install all the Elluminate Live! components. To revise the settings, click the Back button.

22. The Installation Complete screen is displayed.

23. Click Finish to exit the setup.

24. Depending on your operating system, after an install you may have to start the services or daemons. For instructions on how to do this, please refer to the Start, Stop, and Restart the Services and Daemons chapter in this manual.

25. Ensure that the new 7.0 services or daemons are running by connecting a web browser to http://localhost:2187 (substituting your IP Address or hostname in place of localhost). You should get a 400 Goodbye reply.

Or, simply check that the service is running on your operating system.

For example on Windows go to Start > Settings > Control Panel > Administrative Tools > Services. In the list of Services, you should see Elluminate Live! License Manager 1.2, Elluminate Live! Manager 2.0, and Elluminate Live! Server 7.0.

26. Refer to Chapter 6 entitled Post Configuration and Verification on how to update the serversupport email address and to verify that the Server and Manager are up and running properly.
Chapter 4  Custom Installation

A custom installation is generally reserved for the advanced user. It allows you to install individual components of Elluminate Live! on different servers and gives you the option to integrate with Sybase, LDAP or JDBC compliant databases.

A custom install allows you to have different configurations of Elluminate Live! Manager, such as:

- Use of LDAP v3 servers for user authentication and lookups
- Use of Sybase database as an alternative to the default McKoi database
- Use of other JDBC compliant databases where the vendor JDBC jar files are supplied and compatible with Elluminate Live! Manager.
- Component selection of Elluminate Live! You can install the license manager or server separately from Elluminate Live! Manager or install only the Elluminate Live! Manager.
- Customization of the Elluminate Live! Manager system defaults. You can change log file locations, settings, seat reservation method, and labels for display of user roles.
- Multiple Elluminate Live! Servers with one Elluminate Live! Manager

Prerequisites to a Custom Installation

Prior to performing a custom installation, review the following items to ensure that you are configured correctly based on the type of database you will be using.

1. LDAP Attribute Definition

If you will be using LDAP for user authentication and lookups, you must have an attribute that contains values that the Elluminate Live! Manager can process as elluminate roles.

Elluminate Live! Manager uses the Elluminate Role ID to determine the role of the LDAP user. There must be an attribute for the LDAP entry that can be used to determine the role of the user. There are four levels of roles within the Elluminate Live! Manager. The available role IDs and their ordinal value are:

- 0 = system administrator; manages the server, meetings, group lists and users
- 1 = application administrator; manages meetings, group lists, moderators and facilitators
- 2 = moderator or facilitator; manages meetings
Upon installation of Elluminate Live! Manager, you have the choice of either locking out all LDAP users who have no mapped Elluminate Role ID or granting ALL of them access. When a granted LDAP user has no Elluminate Role ID, then the user access defaults to a basic user.

There must be one LDAP user assigned the role ID of 0 (system administrator) to configure and manager the Elluminate Live! Manager.

If you have no such attribute defined, the following definition for the Elluminate Role ID should be applied to your LDAP schema:

```
attributetype ( 5.5.6.8 NAME 'elluminateRole' DESC 'Admin Moderator User' EQUALITY integerMatch SYNTAX 1.3.6.1.4.1.1466.115.121.1.27 SINGLE-VALUE)
```

The LDAP attribute definition should be defined prior to installing Elluminate Live!.

### 2. Password Encryption

If you will be installing Elluminate Live! Manager with encrypted password support and not using the Mckoi database, the manually created server administrator account must have a password that includes a prefix of what it has been encrypted with.

![Tip] Failure to prefix the 3DES or MD5 Hash passwords will result in the user being denied log in access to the Elluminate Live! Manager.

Following is an example of the 3DES encryption method password, where `{CRYPT}` is the prefix that must be included and `AFxKR3w016SRU` is an example of an encrypted password.

```
{CRYPT}AFxKR3w016SRU
```

Following is an example of the MD5 Hash encryption method password, where `{MD5}` is the prefix that must be included and `o0w9RbYBjT/VVgsQPCoA4g==` is an example of an encrypted password.

```
{MD5}o0w9RbYBjT/VVgsQPCoA4g==
```

### 3. Non-Mckoi Database

If you will be installing Elluminate Live! Manager 2.0 using an existing legacy adapter (WebCT Vista 3 or BlackBoard) with a JDBC compliant database (Sybase, Oracle, etc.) and/or using an LDAP
database, then you must create a user in the JDBC compliant database called legacyadapter with a role id of zero.

4. Multiple Elluminate Live! Servers

Having multiple Elluminate Live! Servers will allow for a more even distribution of users on each server. When setting up multiple servers, each server will only need specific components from the installation CD. We recommend customers have a system wide design of how they wish to distribute the load for Elluminate Live! prior to the installation.

The following steps list the components that need to be installed if your configuration was for:

One Elluminate Live! Manager and three Elluminate Live! Servers.

1. Server 1 - Elluminate Live! Manager + License Manager
   Custom Installation Features:
   • Elluminate Live! License Manager
   • Elluminate Live! Manager
   • Common
   • Adapters (if required)
2. Server 2 – Elluminate Live! Server 7.0
   Custom Installation Features:
   • Elluminate Live! Server
   Custom Installation Features:
   • Elluminate Live! Server
4. Server 4 – Elluminate Live! Server 7.0
   Custom Installation Features:
   • Elluminate Live! Server

When configuring each of the Elluminate Live! Servers, you must ensure the following:

1. Each of the Elluminate Live! Servers must be installed with the same license (*.lm) file (defined in step 14).
2. The total number of available seats to be shared by the 3 servers can be defined by setting the appropriate maximum utilization capacity of the server (defined in step 18).
3. Each of the Elluminate Live! Servers have a shared folder available to the Elluminate Live! Manager (defined in step 37).
Chapter 5 Start, Stop, and Restart the Services and Daemons

For example:

\ElluminateLiveServerNumberN\RecordingsExport

The ElluminateServerNumberN server must be accessible from the Elluminate Live! Manager and the RecordingsExport folder must allow read/write access allowing the Elluminate Live! Manager to import recordings from that location.

Refer to the Advanced Configuration Guide – Chapters 4 and 5 for further explanations on recordings and License Management

Console Mode Installation

You can install the Elluminate Live! software in either GUI mode or console mode (command mode). If you wish to invoke the installer in command line mode you may do so by navigating to the Setup folder and then selecting the appropriate OS folder (Linux, Mac, or Solaris). Execute the setup program for your environment followed by the -console option.

Linux & Solaris:

./setupsolarisSparc.bin -console OR
./setupsolarisX86.bin -console OR
./setuploadinux.bin -console

Mac (the following command should be on one line):

java -cp

Follow the GUI Custom Install for a definition of the various panels while installing in console mode.

GUI Custom Installation Steps

1. Insert the CD and browse to the Setup folder.
2. Browse to your OS folder and launch the appropriate setup program. For example:

Windows.
Browse to the CD folder and navigate to \Setup\Windows and double-click on setupwin32.exe file.

**Solaris:**
Open a terminal window, and navigate to /cdrom/elive70/Setup/Solaris Run the appropriate executable
For example: ./setupsolarisSparc.bin

**Linux:**
Open a terminal window, and navigate to /cdrom/elive70/Setup/Linux Run the appropriate executable.
For example: ./setuplinux.bin

**Mac:**
Browse to your CD folder and navigate to elive70/Setup/Mac and double-click on ElluminateLive application.

3. Launch the appropriate setup program (e.g. setupwin32.exe).
4. The Welcome panel appears.

5. Accept the license and then click **Next >** to continue.
6. **Mac ONLY:** You will be asked to provide your password for your account. The account must have administrator privileges. This is required to install Elluminate Live! Server. Click **Next** to continue.
7. Define the location of where you wish to install Elluminate Live!.

The Elluminate Live! software needs to be installed in a directory on the system. The default location are:

**Windows:**
C:\Program Files\ElluminateLive

**Linux & Solaris**
/opt/ElluminateLive

**Mac:**
/Applications/ElluminateLive

If you wish to change the default directory location, click the **Browse** button. The Open dialog box appears. Navigate to the folder you wish to use for the directory and then click **Open** to save the path and dismiss the dialog box.

8. Click **Next >**.
9. Select **Custom**.

10. Click **Next >**.

If you are not installing on a UNIX OS, go to step 11.
11. Select the components you wish to install.

12. Click **Next >**

If you selected:
- Elluminate Live! License Manager, skip to step 14 Elluminate Live! License Manager panel
- Elluminate Live! Server, continue with the next step
- Elluminate Live! Manager, continue with the next step
- Elluminate Live! Server + Elluminate Live! Manager, continue with the next step
- Elluminate Live! Server + Elluminate Live! License Manager, continue with the next step
- Elluminate Live! Manager + Elluminate Live! License Manager, continue with the next step
- All the components, continue with the next step

13. Elluminate Live! server(s) addresses and port numbers.

   The content displayed in the following panel may vary depending on the components you are installing.
Define the addresses and ports for all the servers.

- **Server Address: http://** — enter the hostname or IP address where you will be installing the Elluminate Live! Server.

- **Control Port Number** — the Elluminate Live! Admin Console connects to the Elluminate Live! server on the server’s TCP/IP Control Port. This Control Port must pass through all firewalls between the Admin Console host and the server. The default port number is 2188.

- **Conference Port Number(s)** — The Elluminate Live! client connects to the Elluminate Live! classroom server on the server’s TCP/IP Conference Port number(s). The Elluminate Live! server can listen on a number of Conference Ports. To be accessible, these port numbers must pass through all firewalls between the client and the server. The single default port number is 2187, but alternate or additional ports, generally ports 80 and 443, can be specified to deal with limitations imposed by some firewalls. This can be a single port number or a comma separated list of port numbers.

- **License Manager Port** — enter the port number for the Elluminate Live! License Manager. The default port number is 2186.

- **Elluminate Live! Manager Port** — the Elluminate Live! Manager uses Tomcat (on a default port of 80) to serve up pages to the web clients. You may change this port, but you must ensure that this port number can pass through all firewalls between the web browser and the Elluminate Live! Manager. If you plan on running Elluminate Live! Server on this same machine on port 80 – you’ll need to make some decisions on how to host both services and on which ports.
Generally ports 80 and 443, can be specified to deal with limitations imposed by some firewalls.

- **Remote JDBC Port Number** — enter the port number that allows reporting tools to query the database used by Elluminate Live! Manager.

- **Do not check port** — In order to proceed to the next panel, there must be no service listening on any of the ports. If you have a service currently running on this port AND you will be closing this service after the installation, then check this option. This allows you to proceed to the next panel and continue the install. If no service is running on the port, do not check this option.

---

⚠️ You need to ensure that firewalls allow Elluminate Live! clients to connect through on the conference port you have defined.

🔍 By default the installer runs a check on the defined ports. This test is to ensure that the Elluminate Live! 7.0 Server does not conflict with other services on those ports.
Chapter 5 Start, Stop, and Restart the Services and Daemons

14. Elluminate Live! License Manager

The content displayed in the following panel may vary depending on the components you are installing.

![Elluminate Live! License Manager Panel]

a. Define the address and port of the License Manager server.
   - **Host Name of License Manager** — enter the hostname or IP address of the Elluminate Live! License Manager.
   - **License Manager Port** — enter the port number for the Elluminate Live! License Manager.
   - **Do not check port** — In order to proceed to the next panel, there must be no service listening on any of the ports. If you have a service currently running on this port AND you will be closing this service after the installation, then check this option. This allows you to proceed to the next panel and continue the install. If no service is running on the port, do not check this option.

By default the installer runs a check on the ports. This test is to ensure that no other services are currently running on the ports you are configuring.

b. Select the License type and files
• Choose either the **Demo License** or **Non Demo License** and then select the version of software you will be installing. The choices are Academic, Enterprise, Basic, or Lite. Caution must be taken when selecting the type of Demo License. You should choose the type of license you may be interested in purchasing.

• If you select the Non Demo License, the following panel appears:

![License Selection Panel](image)

- Click on the **Browse** button to navigate to the location of the license file you received from Elluminate and load the license file.

> When installing multiple Elluminate Live! servers, you must use the same license file for ALL of your servers.

15. Click **Next >**.
Chapter 5 Start, Stop, and Restart the Services and Daemons

16. Log Files Folder

Select the folder for the log files.

17. Click Next >.

If you are installing the

- Elluminate Live! License Manager, the Summary Install page should appear. Verify that the information is correct and then click Install to complete the installation.
- Elluminate Live! Server, continue with the next step
- Elluminate Live! Server + Elluminate Live! Manager, continue with the next step
- Elluminate Live! Server + Elluminate Live! License Manager, continue with the next step
- Elluminate Live! Manager + Elluminate Live! License Manager, go to Elluminate Live! Manager General Settings – SMTP Mail Server, step 20
- All the components, continue with the next step
18. Elluminate Live! Server General Settings

The content displayed in the following panel may vary depending on the components you are installing.

Define the following:

- **Elluminate Live! Server Name** — enter the display name for the Elluminate Live! Server. This name may be found in the Preferences > Server Details page.

- **Maximum Utilization Capacity of Server** — enter the number of concurrent Elluminate Live! users that you believe can be supported on the Elluminate Live! Server. Refer to the table defined in the Minimum System Requirements section for a general guideline as to the server capacity based on CPU, RAM, processor type, etc.

- **Elluminate Live! Manager Address** — enter the IP address of the Elluminate Live! Manager.

- **Elluminate Live! Manager Port** — enter the IP address of the Elluminate Live! Manager.

19. Click Next >.

If you are installing

- The Elluminate Live! Server or Elluminate Live! Server + Elluminate Live! License Manager, go to step 37 – Recordings panel;
• Otherwise continue with the next step.

20. Elluminate Live! Manager General Settings – SMTP Mail Server

Define the SMTP email server to use for sending out email notifications:

• **SMTP Mail Server** — the name or IP address of the SMTP server used for email invitations.

• **SMTP Server Port** — the port number of the SMTP server used for sending out email invitations.

• **Mail Server requires Authentication** — a user account and password that Elluminate Live! Manager can use on the SMTP server when sending out email invitations. Note: not all SMTP servers require this extra authentication.

• **Ignore SMTP Server Check**— if you do not have access to your mail server or you are not planning on using the email invitations, select this option. By selecting this option, the mail server will not be validated and you will be able to continue with the installation.

21. Click Next >.
22. Elluminate Live! Manager General Settings (cont.)

Define the Backup Settings:

- **Backup interval in hours** — enter the time interval for backing up the Elluminate Live! Manager database files. The default setting is 24 hours.

- **Number of backups to keep** — select the number of backups you wish to keep. The choices are 1 or All. The default setting is 1.

- **Please choose a folder for Manager backup files** — accept the default location of the Manager backup files or click the **Browse** button and navigate to the location of where you wish to store the backup files. You must include at least one folder to any root or mapped drive. For example H:\Backup. Failure to do this will result in the installation failing.

23. Click **Next >**.
24. Elluminate Live! Manager General Settings (cont.)

These fields define the meeting creation settings on the Elluminate Live! Manager:

- **Boundary Period** — this parameter specifies the number of minutes prior to the scheduled start time of the meeting that a user can launch into the room. The options are None, 15, 30, 45, and 60 minutes.

- **Grace Period** — this parameter specifies the number of minutes that an automatically launched room will stay open after the final participant leaves the room. The options are 1, 5, 10, 15, 30, 45, and 60 minutes.

- **Meetings Require a Password** — this option allows you to set whether a meeting requires a password to join or not. If the check box is selected all meetings will require a password to join, if the option is not checked the meeting creator will have the option of either creating a meeting with or without a password.

- **Seat Reservation Method** — this option allows you to turn the seat reservation feature on or off. Preferred enables the feature, None indicates the feature has been disabled. If the Seat Reservation Method is set to Preferred, while creating or editing a meeting, you may reserve a number of seats for the meeting and check the availability of the seats.

25. Click **Next >**.
26. Elluminate Live! Manager General Settings (cont…)

The Label Definitions are the default names given to the various user roles in Elluminate Live! Manager. You may accept the default values or change the various role labels by entering text into the appropriate text boxes.

27. Click **Next >**.

28. Elluminate Live! Manager Datastore

The content displayed in the following panel may vary depending on the database you are using.
With a custom install, you can choose between the following combinations of databases:

- ELM (Mckoi)
- ELM (Mckoi) + LDAP for user authentication
- Sybase
- Sybase + LDAP for user authentication
- Other (any JDBC compliant database)
- Other + LDAP for user authentication

Select the appropriate database.

If you selected **Use LDAP for user authentication**, the option **Exclude users where the Elluminate Role is not defined or invalid appears**. Selecting this option will only allow LDAP users with an Elluminate role ID attribute defined to access the Elluminate Live! Manager. The LDAP users with an Elluminate Role ID of 0, 1, 2, or 3 will be assigned the appropriate role when logged into Elluminate Live! Manager. If the LDAP user has an Elluminate role ID greater than 3, they will be assigned a participant role.

When this option is not selected, all LDAP users not assigned the Elluminate Role ID attribute will be able to log in to Elluminate Live! Manager — with participant privileges.

If you selected Sybase or Other, the Database Login User ID and Password fields appear. Enter the User ID and Password information for these fields.

If you selected:
• ELM (Mckoi), then go to the Elluminate Live! Manager General Settings (cont...) — Password Encryption method panel, step 35
• ELM (Mckoi) + LDAP authentication, then go to LDAP Configuration – LDAP Connection Settings panel step 31
• Sybase, then continue with the next step
• Sybase + LDAP authentication, then continue with the next step
• Other, then continue with the next step
• Other + LDAP authentication, then continue with the next step

29. Elluminate Live! Manager Datastore (cont…)

a. For the Elluminate Live! Manager to be able to connect to either a Sybase or other JDBC compliant database the JDBC URL and JDBC driver must be defined. If you selected Other, you will also have to supply the Custom JDBC Driver information.

b. You must then add one or more jar files that Elluminate Live! Manager can find the defined JDBC driver. Consult your database vendor for the most recent jdbc driver file(s).

30. Click **Next >**.

If you are installing Elluminate Live! Manager with

• Sybase, go to Elluminate Live! Manager General Settings (cont...) panel Password Encryption.
Chapter 5 Start, Stop, and Restart the Services and Daemons

- Sybase + LDAP authentication, then go to LDAP Configuration
- Other, go to Elluminate Live! Manager General Settings (cont...) panel Password Encryption panel
- Other + LDAP authentication, then go to LDAP Configuration

31. LDAP Configuration – LDAP Connection Settings

If Use LDAP for authentication was selected, then the following details on the server must be provided. These are the details on the LDAP server that will be used by the Elluminate Live! Manager. You may attempt to connect anonymously by leaving the User Name and Password fields blank.

Define the following fields:
- **LDAP Server IP Address** — enter the IP address or hostname where the LDAP server can be found.
- **LDAP Port** — enter the port number that the LDAP server listens on.
- **Base DN** — enter the Distinguished Name (DN) as a frame of reference for all queries.
- **User Name** — enter a user in the LDAP store that has privileges to query LDAP. Elluminate Live! Manager will attempt to bind this LDAP with this user name. This must be the fully qualified user name including the DN.
• Append Base DN — selecting this option will automatically append the Base DN definition to the User Name.

• Password — enter the password for the user name above.

• Confirm Password — enter the password again.

32. Click Next >.

33. LDAP Configuration (cont…) — LDAP Field Mappings

For security reasons, Elluminate Live! Manager does not write back nor store any records in the LDAP datastore, therefore the Elluminate Live! Manager must know what LDAP attributes to use for authenticating a user.

![LDAP Configuration Configuration](image)

Define the following fields:

- **User Password** — enter the LDAP entry attribute that Elluminate Live! Manager will authenticate against.

- **Login Name** — enter the LDAP entry attribute that Elluminate Live! Manager as the Login Name.

- **Given Name** — enter the LDAP entry attribute that Elluminate Live! Manager recognizes as the given name for a user.

- **Surname** — enter the LDAP entry attribute that Elluminate Live! Manager recognizes as the surname for a user.
Chapter 5 Start, Stop, and Restart the Services and Daemons

- **Email** — enter the LDAP entry attribute that Elluminate Live! Manager recognizes as the email address for a user.
- **Elluminate Role ID** — Elluminate Live! Manager uses the Elluminate Role ID to determine the role of the LDAP user. There must be an attribute for the LDAP entry that can be used to determine the role of the user. The available role IDs and their value are: 0 = system administrator; 1 = application administrator; 2 = moderator or facilitator; and 3 = participant or user. If there is no mapping for this role, then all LDAP users by default are assigned a role ID of 3, which is a participant role. There must be one LDAP user assigned the role ID of 0 (system administrator) to configure and manager the Elluminate Live! Manager.

All mappings are mandatory. Failure to map the fields to LDAP attributes will cause issues on logins, invitations, etc.

34. Click **Next >**.

35. Elluminate Live! Manager General Settings (cont…) 

![Elluminate Live! Manager General Settings](image)

Define the following fields:

- **Password Encryption Method** — define the encryption method used to store and retrieve passwords from the database. Select one of the options: Plain Text, 3DES, or MD5 Hash. If you select 3DES or MD5 Hash as a password encryption method for a non-McKoi database you must manually set the serversupport password. Refer to 2. Password Encryption section at the beginning of this chapter for the password encryption definition.
• **Allowable Preloads Formats** — when creating or editing a meeting, the creator can preload multimedia files and whiteboard files. Select the formats you wish to support for multimedia preload and the Elluminate Live! Whiteboard preload.

36. Click **Next>**.

37. **Recordings**

The content displayed in the following Recordings panels may vary depending on the components you are installing. You may or may not have all the fields in each of the panels or you may only see the first Recordings panel.

Both the Elluminate Live! Manager and the Elluminate Live! Server need to have a common directory where the recording files will be written to and recorded from. What you map the recordings folder to will vary depending on your system architecture.

For example, if the Elluminate Live! Manager and Elluminate Live! Server are installed on different machines a drive mapping has to be established so that both Elluminate Live! Manager and Elluminate Live! Server can have access to the same physical directory. For performance issues, the temporary recording folder should be stored on the same machine as the Elluminate Live! Server (defined in step 39).

The recordings folder on the Elluminate Live! Server should be shared so that Elluminate Live! Manager can see and read from the directory.
Define the location of the following Folders:

- Where the Elluminate Live! Server will save the recording files.
- Where Elluminate Live! Manager can retrieve the recording files from.

You may accept the default location or select Browse to navigate to the appropriate location.

If you are only installing the Elluminate Live! Server, ensure that the Elluminate Live! Manager has access to the defined recording folder where the recordings will be written to.

38. Click Next >.

39. Recordings (cont…)

40. Click Next >.

If you are installing the Elluminate Live! Server, continue with the next step; otherwise go to the Elluminate Live! Heap Size panel, step 43.
41. Elluminate Live! Bandwidth Utilization

Set the limit of the network bandwidth for the Elluminate Live! Server.

42. Click Next >.
43. Elluminate Live! Heap Space

Allocate the amount of space that you wish the Elluminate Live! servers to utilize.

44. Click Next >.
45. Installation Summary

![Installation Summary Screen]

The summary information will vary depending on the components you selected to install. Read the summary information carefully.

46. Click **Install**.

47. The Installation Complete screen is displayed. Click **Finish** to exit the setup.

48. Depending on your operating system, after an install you may have to start the services or daemons. For instructions on how to do this, please refer to the **Start, Stop, and Restart the Services and Daemons** chapter in this manual.

49. Verify that the Server and Manager are running and configure the serversupport email address.

   Follow the steps listed in the chapter called **Post Configuration and Verification**.
This page was intentionally left blank.
Chapter 5  Start, Stop, and Restart the Services and Daemons

You can manually start, stop, or restart the Elluminate Live! License Manager, Elluminate Live! Manager and Elluminate Live! Server services and daemons.

Windows

What are services? By definition, services are programs that run invisibly in the background. Services load and start running whether or not anyone logs into the computer, unlike a program that is launched from the Startup folder under Programs.

There are two ways to view the Services on your computer. One method is to use the Services window. The Services window provides a quick overview of all the services on your computer. This is the only method that is described here.

To start, stop, or restart a service, do the following:

1. Open the Services window
   To open the Service window, click Start > Settings> Control Panel, double-click Administrative Tools, and then double-click Services.
2. The Services window appears.
Chapter 5: Start, Stop, and Restart the Services and Daemons

3. Right-click on the appropriate service and select the action from the pull-down menu.

Looking at the Services window you can see it has columns for Name, Description, Status, Startup Type, and Log On As. Detailed information is available on each service by double-clicking on any of the entries.

Linux, Solaris

What is a daemon? By definition, a daemon is a computer program that runs in the background, rather than under the direct control of a user. Typically daemons have names that end with the letter "d", for example *elm2_0d* is the daemon, which handles the Elluminate Live! Manager.

The following table lists the command to stop, start, and restart the Elluminate Live! daemons.

<table>
<thead>
<tr>
<th>Daemons</th>
<th>Action</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>License Manager</td>
<td>Stop</td>
<td>/etc/init.d/ellm1_2d stop</td>
</tr>
<tr>
<td></td>
<td>Start</td>
<td>/etc/init.d/ellm1_2d start</td>
</tr>
<tr>
<td></td>
<td>Restart</td>
<td>/etc/init.d/ellm1_2d restart</td>
</tr>
</tbody>
</table>
Daemons | Action | Command
---|---|---
Manager | Stop | /etc/init.d/elm2_0d stop
 | Start | /etc/init.d/elm2_0d start
 | Restart | /etc/init.d/elm2_0d restart
Server | Stop | /etc/init.d/elived7_0 stop
 | Start | /etc/init.d/elived7_0 start
 | Restart | /etc/init.d/elived7_0 restart

The restart command is not supported on Solaris.

Macintosh

The following table lists the command to stop, start, and restart the Elluminate Live! services.

<table>
<thead>
<tr>
<th>Services</th>
<th>Action</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>License Manager</td>
<td>Stop</td>
<td>sudo SystemStarter stop eLiveLicenseManager</td>
</tr>
<tr>
<td></td>
<td>Start</td>
<td>sudo SystemStarter start eLiveLicenseManager</td>
</tr>
<tr>
<td></td>
<td>Restart</td>
<td>sudo SystemStarter restart eLiveLicenseManager</td>
</tr>
<tr>
<td>Manager</td>
<td>Stop</td>
<td>sudo SystemStarter stop eLiveManager</td>
</tr>
<tr>
<td></td>
<td>Start</td>
<td>sudo SystemStarter start eLiveManager</td>
</tr>
<tr>
<td></td>
<td>Restart</td>
<td>sudo SystemStarter restart eLiveManager</td>
</tr>
<tr>
<td>Server</td>
<td>Stop</td>
<td>sudo SystemStarter stop eLiveScheduler7_0</td>
</tr>
<tr>
<td></td>
<td>Start</td>
<td>sudo SystemStarter start eLiveScheduler7_0</td>
</tr>
</tbody>
</table>
### Chapter 5 Start, Stop, and Restart the Services and Daemons

<table>
<thead>
<tr>
<th>Services</th>
<th>Action</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restart</td>
<td></td>
<td><code>sudo SystemStarter restart eLiveScheduler7_0</code></td>
</tr>
</tbody>
</table>
Chapter 6  Post Configuration and Verification

After installing the Elluminate Live! software, you must update the serversupport and legacyadapter’s email addresses in the Elluminate Live! Manager application. By default, both of these users do not have valid email addresses.

Configure the serversupport’s and legacyadapter’s email addresses

1. Access Elluminate Live! Manager, from a web browser.

   Enter the URL of the Elluminate Live! Manager. The public Meetings page appears.

   ![Elluminate Live! Manager](image)

   Copyright ©2004-2015 Elluminate, Inc. All Rights Reserved.

2. Login to Elluminate Live! Manager.
Chapter 6 Post Configuration and Verification

a. Enter **serversupport** for the User ID textbox and **elluminate** for the Password (This is the default userid and password with a typical installation).

b. Click the Log In button.

3. Configure the serversupport’s email address

   a. Click on the Users tab. The Users page appears.

   b. Click on the **serversupport**. The Modify User page appears.

   c. Click on the **Edit button**. The Modify User page appears.
c. Enter a valid Email address.

d. Modify any of the other default values, if you wish

e. Click **Update** to save and apply the changes.

f. Logout.

4. Configure the legacyadapter’s email address.

   a. Login as **legacyadapter**, password **elluminate**.

   b. Click on the **Users** tab.

   c. Click on the **Edit** button for legacyadapter. The Modify User page appears

   d. Enter a valid email address and then click **Update**.

   e. Logout.

### Verify that the Installation was Successful

To determine whether the server and manager you installed are running, we recommend that you:

1. Create a meeting.

2. Send an email notification to the meeting.

3. Join and record the meeting.
4. Playback the recorded meeting.

Follow the steps listed below to create a meeting, send an email notification, launch into the meeting, record the meeting, and finally playback the recorded meeting.

1. Create a Meeting
   a. Login as serversupport, password elluminate.
   b. Click on the Meetings tab to return to the Meetings page.
   c. Click on the link ‘To create a new meeting click here’.
   d. The create_meeting.html page appears.
   e. Create a basic meeting. You may keep the default values and just click on the Submit button.
   f. The Meeting Details page appears.
g. Click on the click here link in the To send email invitations click here.

h. The Email Invitation Templates window appears. Select Submit to send the email.

i. An Email Confirmation page should appear indicating that the Email Invitations were sent. Close this window. The email message should be sent to the email address you gave for the serversupport user.

j. Close the Email Confirmation window.

k. You should be returned to the Meetings Details page.

l. Click on the click here link in the To return to today’s schedule click here.

The email message should have been sent to the email address you gave for the serversupport user. If they received the email invitation, then you know that your SMTP Mail Server has been configured correctly.

2. Join the meeting as the moderator.
   a. Click on the meeting name link in the list of meetings. The join_meeting_confirmation.html page appears.
Chapter 6 Post Configuration and Verification

b. The Opening meeting.jnlp window appears. Click the Ok button.

c. Click the Yes button in the Warning – Security window.

d. You should be launched into the Elluminate Live! room as the moderator.

3. Record the meeting.

a. Click on the Record button in the Status bar at the bottom of the window.

b. OK theConfirm recorded start message. The recorder should now be running.

c. Perform some action, for example, click on the Talk button and talk, draw a circle on the whiteboard, send a text message, etc.

d. Exit the session (File > Exit).

4. Playback the recorded meeting.

a. Return to the Meetings page. If the join_meeting_confirmation.html page is still open, click on the link ‘Click here to return to today’s schedule.’

b. Click on the Recordings tab in the Elluminate Live! Manager.

c. Click on the recorded meeting name link in the list. You should be launched into the Elluminate Live! room and the recording should start shortly.
Chapter 7  Uninstalling Elluminate Live!

This section describes how to uninstall the Elluminate Live! services and to clean-up the InstallShield folder.

Windows Uninstall

1. Select one of the following to uninstall Elluminate Live! 7.0 with Elluminate Live! Manager 2.0:
   - Go to Start > Programs > Elluminate Live > and select Uninstall Elluminate Live! 7.0 with Elluminate Live! Manager 2.0
   - Run the `uninstaller.exe` executable by navigating to `C:/Program Files/ElluminateLive/_uninst` and double-clicking on `uninstaller.exe` file.
   - Use the Windows Add Remove Programs
     - Go to Start > Settings > Control Panel > Add Remove Programs.
     - Scroll through the list and highlight Elluminate Live! 7.0 with Elluminate Live! Manager 2.0
     - Click the Change/Remove button. The Uninstall setup program starts.
     - Follow the on-screen prompts.

2. Delete the Elluminate directory from the InstallShield folder
   For example, browse to `C:\Program Files\Common Files\InstallShield\Universal\Elluminate` and delete the Elluminate folder.

Linux & Solaris Uninstall

There are two methods you may use to uninstall on a UNIX platform — the GUI Mode or Console Mode uninstall. Both methods are described below.
GUI Mode Uninstall

1. Open a Terminal window and navigate to the _uninst folder. The default location is /opt/ElluminateLive/_uninst

2. Execute the uninstaller.bin script. For example, at the prompt enter the command: ./uninstaller.bin

3. The Welcome panel appears.

4. Click **Next** to continue

5. The Summary panel appears
6. Click **Uninstall** to uninstall the Elluminate Live! 7.0 with Elluminate Live! Manager 2.0

7. Upon a successful uninstall, the following panel appears

8. Click **Finish** to exit the Install Wizard.
Chapter 7 Uninstalling Elluminate Live!

9. Remove the Elluminate folder from the InstallShield folder
   Browse to /InstallShield/Universal/Elluminate located in the Root folder

Console Mode Uninstall

1. Open a Terminal window and navigate to the _uninst folder.
   The default location is /opt/ElluminateLive/_uninst

2. Execute the uninstaller.bin script.
   For example, at the prompt enter the command: ./uninstaller.bin -console

3. Follow the on-screen prompts to uninstall the Elluminate Live! 7.0 with Elluminate Live! Manager 2.0.

4. Remove the Elluminate folder from the InstallShield folder
   Browse to /InstallShield/Universal/Elluminate located in the Root folder

Mac Uninstall

There are two methods you may use to uninstall on a Mac OS — the GUI Mode or Console Mode uninstall. Both methods are described below.

GUI Mode Uninstall

1. Run the uninstaller.command script located in the following default location:
   /Applications/ElluminateLive/_uninst/uninstaller.command

2. Remove the Elluminate folder from the InstallShield folder
   Browse to /InstallShield/Elluminate located on the Root folder.

Console Mode Uninstall

From the command line, type the following: ./uninstaller.command -console

This script is located in the Applications/ElluminateLive/_uninst folder.